Wacom One 13 with MyPaint

hi, i am trying to use mypaint with the new wacom one 13, but there’s no detection of the tablet(the gtk demo says system aggregated pointer) and there is no pressure detection, just to the max.
is there a way to correct this or mypaint does not support the latest wacom tablets ?
(i tried the last stable mypaint version 1.2.1 and the 2.0.0 alpha 13.)

Windows 10 pro
gtx 960M
8gb ram
Inspiron 7559

1 Like

MyPaint doesn’t handle the tablet interface. That part is handled by Gdk, which is a library that MyPaint depends on. Try your tablet with a recent version of GIMP - if it works there I think there is a good chance that we can make it work in MyPaint in a future release (currently the input handling uses a bunch of deprecated interfaces, and that may be the underlying cause of your tablet not working).

1 Like

ok, it doesn’t seem to be working in gimp at the moment

Yeah, since that Display Tablet just came out, it going to be a bit before driver support is going to be added. I’m sure they are working on. What about Krita? They use a different gui stack for tablet support, dose it work there?

Edit: You can go here: https://github.com/linuxwacom and see if someone open a ticket regarding this Display Tablet. Otherwise you can open your own ticket requesting support or wait and see. I’m sure it just a matter of adding its unique identifiers, but I’m no driver developer.

Oh looks like support for the Display tablet has been committed, so it’s just a matter of time when they’ll release a new version of the driver which the next version of GDK will take advantage of. So just hold tight. I believe the release of the next GTK/GDK is going to be sometime next month if I’m not mistaken.


krita seems to have no problem, except that, like in mypaint, i can’t have two active screens while using the software or the tablet draws with an offset. With only one screen theres no problem

Hi odysseywestra…

I just posted my own version of this issue. Mine involves a Wacom MobileStudio Pro 13.

Only saw this post after! Sorry about that.

Do you have any idea if it’s possible for me to employ some sort of workaround to get the GTK/GDK driver updated? Any thoughts on how to accomplish such a thing?

(I’m on Win10. And it seems like GTK/GDK has something to do with Linux? But I’m probably wrong.)


Blue skies

The whole gtk stack is due to be released in a few weeks. So it would be best to wait atm.

Hi Folks…

I’ve just installed MyPaint 2.0.0+git.af5225a2 on my Wacom MobileStudio Pro 13.

I’m running Win10, 64 bit.

Unfortunately, it seems as though the stylus is completely unrecognised. Only the mouse seems to be recognised by MyPaint.


  1. I’ve checked my Wacom drivers. They’re fully up to date. (I use Krita as my primary drawing app, and the stylus is fully recognised there. No hassles.)

  2. I’ve attempted to mess around with the settings in MyPaint 2 to see if I can get some sort of breakthrough. But it appears that MyPaint believes that the only input device present on my machine is my bluetooth mouse. In other words, it seems to think that the stylus is completely absent. Doesn’t exist.

  3. I’ve tried disabling Windows Ink in my tablet settings. That does nothing. Re-enabling it does nothing too.

  4. I’ve tried running MyPaint in Win 7 and then Win 8 compatibility mode. No change.

  5. I’ve tried restarting Wacom Professional Services. No change.

  6. I’ve installed and run WinTab64. No change, regardless of whether or not WinTab is running.

  7. I’ve scoured the internet for possible clues to this issue, and nothing seems to be coming up.

  8. One potential issue is that I’ve got Python 2.7.17 installed on my machine. I’m wondering if this is causing some sort of clash? (I don’t have version 3+ installed because another app I’ve got won’t run on 3+.)

No error messages appear. And MyPaint appears to be operating correctly. I’m able to draw successfully with my stylus, but with absolutely no line variation. Drawing doesn’t appear to lag. Nothing’s slow. I can import and export images.

This is a superb piece of app-machinery!

If only I could find some sort of workaround to get pressure working. That would be rather awesome!

Blue skies

Greetings All,
I have similar issues with my Xp-Pen Deco03.
Full story on Github post:

I hope this gets resolved quickly cause I fell in love with Mypaint after just a few hours using it.

Have a good one,

Update: the problem seems to be resolved for me; I re-installed the pen driver after re-installing the program (instead of installing the the program while the driver is already installed).

Update2: I just noticed that the ‘relative/absolute mode’ toggle in the pen settings can screw up the pen’s working: the relative mode ‘breaks’ the pen functionality.

Update3 (Re-posted from Github):

I wrote to XP-Pen, and this was their reply, FYI:

Thanks for contacting us. Relative mode is mouse mode and it doesn’t support windows ink and wintab. Hence when the tablet is in relative mode, some drawing software still can draw but no pen pressure. And we have also tested MyPaint. The pen can’t write when tablet is in relative mode. It is the same when tested other tablets on MyPaint. Hence maybe MyPaint doesn’t allow handwriting when tablet is in relative mode.

So the issue is with Windows Ink (& WinTab) compatibility. Maybe this is an item for an FAQ, to inform others who may be dealing with the same issue?

Take care,

Hi guys…

Any progress yet in getting MyPaint to recognise the stylus on the Wacom MobileStudio Pro?


No explicit work on our end, but the latest build should have a newer version of Gtk, so you could try that and let us know if that has fixed it (use the standalone version, e.g. the 7z archive): AppVeyor

Edit: didn’t notice the date on the question. Better late than never I guess.

1 Like