Point stroke

Please fill out the topic template below so we can help you faster.

Description of the Problem, or Question?

I have a touchscreen laptop I use for tutoring math. When I poke the screen, as in writing a period, I would like for the brush to paint the dot I just poked at, rather than just move the mouse there.

Basic System Details

Linux Mint 19.3

MyPaint version:

Found under Help --> About MyPaint

Operating System + Version:
Linux mint 19.3, XFCE

Please include Desktop Environment if on Linux

Make and Model # of Graphic Tablet:
um, Amtel touchscreen? ASUS Q302L laptop? it also does this with any kind of mouse.

Please Tell Us How to Reproduce the Problem in Steps.

With the pen enabled, click & drag the mouse across the screen. See how it leaves a stroke?
Now simply click without dragging. See how it doesn’t leave a stroke?

Are there any Errors Popping Up? If so, paste the text in the area shown below.


For our guidelines to create a great user support ticket, please visit this wiki page at https://github.com/mypaint/mypaint/wiki/Reporting-Bugs#reporting-guidelines

Look under preference >> Devices. I believe you can change the behavior of certain mouse devices. Plus you might need to fiddle with the brush settings since most need a certain amount of pressure before they register.

The easiest way i know of, is to create a new brush preset for this case.

  • To make a dot always full opacity when using a pen, make sure the “Opacity multiply” Setting in your Brush Settings (Ctrl+B) looks like this:


  • To make a brush create dots, even when there is no cursor movement when clicking, use the “Dabs per second” setting and try a value around 30 (it’s the only way i know of)


  • Save that as a new brush preset and use it instead of the previous default brush. It should work for both mouse and pen equally.