MyPaint will not save or export anything ever

Description of the Problem, or Question?

MyPaint worked perfectly on this computer a few months ago, but now any attempt to save or export, in any format, to any location, produces a “Failed to write” error and does nothing. I’ve uninstalled and reinstalled the program twice from fresh downloads, to no effect. (I also tried the standalone version, but it won’t even run, throwing a “Cannot update location state file!” error, but I guess that’s another ticket.)

Basic System Details

MyPaint version:

MyPaint w64 1.2.1+gitexport.bcf5a28d
(Python 2.7.13, GTK 3.22.7, GdkPixbuf 2.36.4, Cairo 1.15.4, GLib 2.50.1)

Operating System + Version:

Windows 10 Home, fully updated

Please Tell Us How to Reproduce the Problem in Steps.

  1. Run MyPaint
  2. Draw a squiggle
  3. Click file > save
  4. Specify any filename, format, or save location and click “save”

Are there any Errors Popping Up? If so, paste the text in the area shown below.

Failed to write ".tmpsave.x.png".

Reason: [Errno 2] No such file or directory: u'C:/Users/(my username)/Desktop/.tmpsave.x.png'
Target folder: "C:/Users/(my username)/Desktop".

I can’t reproduce this with either 1.2.1 w64 standalone or the latest appveyor build on a VM running Windows 10 Enterprise (browser testing version). Does your username contain some non-ascii characters or maybe whitespaces or have you modified the write permissions on the folders you’re trying to save to? Maybe a recent update made access requirements stricter? Just speculating here.

Did you do anything that might be a clue to the cause, such as installing a newer version from git or similar?

Thanks for looking into it. I’m not surprised you couldn’t reproduce it, since I can’t find any record of anyone but me having this problem. However, my username has no special characters, and I haven’t changed any write permissions at all in the six-month stretch since MyPaint didn’t have this problem on this same computer. Besides windows updates, I can’t think of anything that’s changed about this system in that time. (Aside from me repeatedly uninstalling and reinstalling MyPaint trying and failing to fix this.)

I get a “permission denied” error, predictably, if I try to save to e.g. the root of the C: drive – but if I try to save to the desktop, it doesn’t say permission denied; it claims the desktop folder doesn’t even exist.

However, I just discovered that I am apparently able to save to /Users/(my username/Downloads . So far that’s the one and only location that will allow a successful save.

If you create a new folder “test” directly under C:\Users{your username}\ , are you able to save to that folder? The most logical explanation here seems to be that something changed the permissions of the desktop folder (and its subfolders).

I would normally ask people to try out the newer builds (such as the one I linked to previously), but I don’t think that will make a difference. Your problem with the standalone version also suggests that it’s a permission problem, as the executable needs to create a file (_location.txt in the same folder as the exe) as part of its first run.

For what it’s worth, I finally found the root cause, and the solution. At some point this year, Windows Defender’s “Controlled Folder Access” feature spontaneously and covertly began to block MyPaint (and a few other programs) from saving anything to any folder besides Downloads, totally regardless of any folder permissions set, and without any notification. Once I found the blasted setting, I turned it off with one click and everything started working again. Anyway, thanks for the help.

Glad to hear it was resolved at least! Linux may not be the greatest in terms of ease of entry, but at least we’re mostly spared from that particular kind of nonsense. I’m sure the intentions of those increased restrictions were good, but not notifying the user about it seems very strange to me.

1 Like