MyPaint not Launching on Windows 10

I have a SONY portable UPDATE A W 10, but is updated each Mypaints me i blocks any

So we can understand. You have a Sony Laptop which has upgraded to Windows 10. However, MyPaint will not to work on Windows 10?

Using Google Translate:

Así podemos entender . Usted tiene una computadora portátil de Sony que ha actualizado a Windows 10. Sin embargo , MyPaint no va a trabajar en Windows 10 ?

Usando el traductor de Google

Related topic on GIthub:

@achadwick This is the third time this has been reported, what do users need to provide so we can figure out what is causing it?

Our (recent, since 1.2.0-betaSomething) Windows releases come with a debug-mode launcher for the start menu, so people don’t need to use a command line normally. Users can click on the Start menu and search for “MyPaint w64 (console debug)” or its w32 equivalent.

This launcher makes MyPaint run slowly with lots of debugging info inside a console window. The final messages from the console can be cut and pasted into triple backtick quotes in Github:

(debugging junk here)

It’s normally the last messages we need.

I love mypaint and with a new computer I am now encountering this issue. I hope it gets fixed soon. :frowning:

(python2.exe:3900): Gdk-CRITICAL **: _gdk_win32_display_create_window_impl: assertion ‘display == gdk_display_get_default ()’ failed

@Kat_F Please try the latest beta. It should be fixed now.

If it isn’t fixed, please help us disentangle because that’s still a mess :smile_cat:

i still have the same problem. (program not launching. i tried version 1.2.0, and 1.2.1

unfortunately, this is all i got from the console:

INFO: mypaint: Debugging output enabled via MYPAINT_DEBUG
Fatal Python error: PyThreadState_Get: no current thread


I’ve had the same issue (frankly scary as it was just my top favorite drawing program) and I’ve solved it.

Please try the following steps:

  • Turn off anti-virus (I have avast)
  • Download instaler (i’ve managed to get the latest beta version working)
  • Don’t open it imediatly, go to the file properties and check if the file is blocked, sometimes windows does that for security reasons, if so, unblock it. Still on the file properties go to compatibility settings and turn on for Windows 7 and run as administrator, click ok to close the properties window.
  • Run instaler AS ADMIN, i’ve noticed it seamed to take more time to install this time
  • After it finishes, run the program AS ADMIN

Worked for me, hope it helps