MyPaint 2.0.0beta0 Fedora 33 Jam install lacking pressure sensitivity with Huion Inspiroy H640P

Subject states the problem.

Fedora 33 Jam


Linux - Fedora 33 Jam

KDE Plasma

Huion Inspiroy H640P

Draw with stylus. Pressure sensitivity works with Krita 4.3.0, so this isn’t a driver issue, as far as I can tell.

Hi there,

  • Just to make sure: Have you tried different brushes that make use of pressure?
  • can you run gtk3-demo --run=event_axes and see if pressure is displayed as you press down the stylus?
  • Can you show us what is displayed on the window in “Help > Debug > Test Input Devices” as you slightly move/press the stylus inside the canvas area?
1 Like

Yes, I have tried what look like different brushes that use pressure. Completely new to MyPaint. gtk3-demo doesn’t exist on my system and I have no candidate to install. I have a screenshot, but the forum doesn’t seem to accept uploads…

I can however add, that the debug window says:

Pressure: (no pressure)
Tilt: (no tilt)
Barrel Rotation: (no barrel rotation)

Try running mypaint in terminal


Fedora sets GDK_CORE_DEVICE_EVENTS for KDE sessions.
It was added in Fedora 22 as workaround for problems with scrolling in Firefox.
Added in Fedora bug: 1226465 – GTK applications (sometimes?) do not scroll correctly, lacks focus?
Variable is set in /etc/xdg/plasma-workspace/env/

Related mypaint bug: mypaint fails to detect tablet on fedora 22 · Issue #388 · mypaint/mypaint · GitHub

No change. Still the same problem.

Well, I finally got MyPaint working properly, but I had to go about it rather drastically. I erased my Fedora 33 install and replaced it with the latest Debian Buster Cinnamon (debian 10.7) with MyPaint 1.2.0+gitexport.f62444e. Now I can hopefully spend my time learning to draw and paint, rather than spending all of my time trying to get my computer sorted out. Thanks for the posts.

It was actually not a Fedora vs. Ubuntu thing, it was a libwacom thing that was getting in the way. Around the time of your post, the libwacom team was doing a great deal of work and they changed the way they assign the targets from udev several times in rapid succession. This resulted in lots of broken things which required quite a bit of tweaking for the udev files, the digimend kernel module source, the xconfig files in /usr/share/X11/xorg.conf.d, as well as /usr/share/libwacom. Eventually, (March/April IIRC) things settled down and now ALL of the configuration can be done by adjusting the files in /usr/share/libwacom… As an aside, if you wanted to see the raw output of your devices attached to your Xwindow System, get the package named evtest. It really helps troubleshooting and verifying configs.

I had two of the H640P tablets and the curious thing was they both showed up differently to udev. That was frustrating all on it’s own, but almost every time that I had it working just right (all buttons on the pad and the stylus as well as z-distance, 8192 pressure and tilt function) libwacom would have a system update and it would break it again. Eventually and sadly, the functionality of tilt has evaporated, but now EVERYTHING else just works. Fedora34 and Ubuntu 20.04 (20.10) for both arm and x64 just work (no tilt). There is no longer any need to download seperate kernel module because it seems that the digimend source was incorporated into the mainline kernel now. Hooray for tablet support!!! I hope that helps Linux becomer more accepted by the creatives… We could use some nice applications :slight_smile:

As for configuration for the pressure and such for the stylus and the button assignments, initial setup should be done in the wacom configuration panel. If you don’t have that, then your tablet probably isn’t directly supported by their project. I will get into how to do that somewhere else… this is getting TLDR pretty fast.
If your tablet does show up in the config panel, then you can just go to the preferences menu in Mypaint and change it there. Just so you know, there will likely be some devices that show up that are just wrong. That is because of the udev rules and the way tables present themselves. You can concentrate on Pen and Pad for your device as those are the only 2 that mean anything. Pad is for buttons and Pen is yeah…

I hope this helped someone.