My file suddenly won't save; only saves as a different file with ".tmpsave." in front of the name

Description of the Problem, or Question?

I left my computer on sleep mode for about a day (I’ve left it for much longer, and this hasn’t happened), but when I came back to continue what I was working on (called “Body value shading attempt,” which is about 15,000 KB) and try to save it, it hits me with an error message saying it can’t save because the file is being used by “.tmpsave.Body value shading attempt,” which is only 1 KB. Trying to save the file somewhere else just saves it as another .tmpsave., also 1 KB. Opening the original save file has a huge chunk of my work missing (including work I swear I’d saved before this, it’s like it just deleted a whole layer), and opening the .tmpsave. file gives me another error message. It says when I try to close Mypaint or anything that I’ll lose 15 minutes of drawing, and want to avoid that if I can.

Basic System Details

MyPaint version:
MyPaint w64, 2.0.1+git.478280f2
(Python 3.8.3, GTK 3.24.20, GdkPixbuf 2.40.0, Cairo 1.16.0, GLib 2.64.1)

Operating System + Version:
Windows 10 64 bit

Make and Model # of Graphic Tablet:
One by Wacom, CTL-472, CTL-672

Please Tell Us How to Reproduce the Problem in Steps.

I worked on this project for a while, then put my computer into sleep mode, leaving Mypaint open like I usually do and have done with this file. I didn’t work on anything the next day, then I came in today to continue working. I went to MyPaint to do something else, and tried saving just to be safe before I opened a new file, and that’s when I started getting the error message.

Are there any Errors Popping Up? If so, paste the text in the area shown below.

Here’s the error message I get when trying to save:

Failed to save “Body value shading attempt.ora”. Unable to write “C:/Users/ASUS/Documents/Art-Video Projects/MyPaint Art/Studies, Practice/Body value shading attempt.ora”: [WindError 32] The process cannot access the file because it is being used by another process: ‘C:/Users/ASUS/Documents/Art-Video Projects/MyPaint Art/Studies, Practice/.tmpsave.Body value shading attempt.ora’

And here’s the one I get when I try to open the .tmpsave. file:

Could not load “.tmpsave.Body value shading attempt.ora”.
Error loading “.tmpsave.Body value shading attempt.ora”.
Reason: File is not a zip file
The logs may have more detail about this error

I should say that if either of the error messages have any typos or incosistencies, that’s because I couldn’t highlight the error messages to copy-paste them here, so I typed them in, so those typos come from me not the error messages.

That’s odd.

What happens if you try to save it to a new file? Like “Body value shading attempt 2.ora”

Edit: Never mind… I missed that part of your post.

Edit 2: If you unzip your file, every layer should be a png. Maybe your lost work is on one of them? With a bit of luck it’s just the xml file that has been corrupted.

Good news; I managed to copy-paste the deleted layer into the original file from the corrupted one I had left open. Saving that file and closing the corrupted one seems to have worked; I can open and save the the file with no problem. I can only assume something went wrong specifically with the MyPaint window I left open and not the file itself, but I’m not sure since I don’t know too much about computers. I’ll either post here again or start a new discussion if I have any more issues. Thanks for the help.

1 Like

From what I understand, one solution is to disable ransomware protection in windows as controlled folder access is what causes mypaint to be unable to save sometimes. I see it happen occasionally in other programs as well.

I see this problem pretty often on these forums though. There’s quite a few posts spread throughout here on it.