Issues with active pen on Lenovo Yoga

Description of the Problem, or Question?

I’m trying out drawing on a Lenovo Yoga with touch display and interactive pen. Pressure sensitivity works, but when lift the pen after drawing a line, mypaint doesn’t stop drawing the line, but instead when I next come close to the surface, it draws a straight line from the end of my last line to the new position. See the lines which I marked green here:

I also noticed that the curves of my lines aren’t smooth, but have corners, see the lines I marked red. Overall, drawing feels a bit laggy even when slow position tracking is turned off.

However, if I plug in my old Wacom Bamboo and use the exact same brushes, everything works fine, no weird lines or jagged curves, and most notably the brush reacts a lot faster and the response feels more immediate. CPU usage looks the same in both cases.

I was wondering whether this is an issue with GTK and I need to report it there? How do I find out?

Basic System Details

MyPaint version: It happens both with 1.2.0 and a self-compiled version from git.

Operating System + Version: Debian Stretch with Kernel 4.12 and Gnome 3.22

Make and Model # of Graphic Tablet: Lenovo Yoga 900s laptop with touch display and Lenovo ThinkPad Pen Pro. The pen shows up as its own device of type “Pen” in MyPaint’s device list.

Please Tell Us How to Reproduce the Problem in Steps.

Just regular drawing.

Are there any Errors Popping Up? If so, paste the text in the area shown below.

No, nothing popping up an nothing in the console output.

Have you tried the gtk3-demo? Maybe you can see if acts weird there, then it definitely maybe is a gtk issue: I didn’t know where it was on linux until just now:

apt install gtk-3-examples


Looks really neat w/ my Art Pen rotating barrel :wink:

The Yoga isn’t my laptop, so I couldn’t try out the demo right away.

What I notice with the demo and the active pen is that when I stop “drawing a line”, the pointer is stuck at the end position for a bit, even if I keep the pen close to the surface, and only starts following the actual pen position again after a bit of delay. I think when it picks up the new position again, that’s exactly when MyPaint draws the unwanted straight line. So I’d say there’s definitely something wonky with gtk, but I can’t say who is at fault for that unwanted line, which is the most annoying issue with the pen right now. The slowness is there in the demo as well, but it doesn’t bother me much since it feels like slow position tracking. I don’t know about the jagged lines since the demo doesn’t actually draw any lines so it’s hard to see how smooth the movement is. It looks okay in the demo, but then, the effect isn’t very strong.

With the wacom tablet, when I lift the pen far enough away from the tablet that it can’t pick up the position anymore and then set it down again at a new position, MyPaint doesn’t draw any unwanted lines, so there must be something different going on with the active pen, even it in the gtk-demo the effect looks the same.

EDIT: How does the whole gtk lib thing work, I wonder? Could I compile the gtk libs from source and use them to compile MyPaint against without having to switch the rest of the system over?

I don’t know how hard it would be to compile from new gtk sources, but I think that’s a last resort. I would try these:

Try another program like Krita, does that have an issue too?
Try disabling Multitouch in the OS
In MyPaint, set all the other devices to “ignore” except the pen

Let me know if that helps!

I also have this issue on my surface pro 3, when ever i lift my pen to start drawing again a line is drawn from the last position. for that fact and also that the brushes tend to lag i still use version 1.0 for sketching.

1 Like

I have tried Krita as well as Gimp. Same issues, though the random straight line seems to happen less frequently. I had disabled all other devices for painting in MyPaint already since I kept accidentally drawing with my palm. I don’t think multi touch is enabled at all? At least I can’t find any settings and nothing seems to happen if I try anything, though I have to admit I usually don’t use tablets.

Under Windows 10, I don’t have the straight lines and jagged edges, but no pressure sensitivity, and it’s also a bit laggy. MyPaint only shows the system pointer as a device. The sketch app that comes with Windows works fine, though, so it’s not an issue with the pen itself.

I will try MyPaint 1.0 next, thanks for the suggestion!

Another thought is that maybe (a BIG maybe) you have the wrong pen for the device and that is causing some weirdness:

The Thinkpad Pen Pro is not specifically compatible with the 900S. The site above mentions the Thinkpad Pen Pro has a bigger hover range so it might be slightly different hardware. You should have part # GX80K32882, not 4X80H34887

That said, I doubt that’s the problem but might be worth a shot especially if you can somehow try the GX80K32882 pen for free at a store somewhere. Or maybe it’s a good idea to have spare pen :wink:

Guys, how did you solve this issue? Im having problems with my pen as well now. I dont even touch the screen and the computer continue to write. so my writting is a mess, as there is no ‘vspace’’ created when I lift the pen away from the screen.

1 Like

Have you tried uninstalling the wacom Pen Setting app (in apps & features).
Worked for me.

hi, i am having the same problem, and mine are worst, the pen is inaccurate when I do my painting, the ink didn,t go with the stylus, it goes to the right of the cursor,
so, I wonder have you solved this problem?

if you do please tell me how.

you can send me an email :
or contact me on facebook my name is “Aiman Arif”.

thank you.