Huion H950P Tablet Issue

Description of the Problem, or Question?

I have just signed up as I am having similar issue to another post but it for a different tablet version so created my own post here.

Just purchased Huion H950P last Friday. Installed drivers, downloaded 14.5 and was successfully using MyPaint that night. Under devices the Huion tablet showed up and I have about 3-4 hours of use.

As this tablet is meant to work with Tilt, I thought I would try find out what programs would work and unknown if MyPaint supports it. Found out a Firmware upgrade is required for the Tablet and found the download for it. The firmware did not work for me. Then the Huion application had an update which I downloaded 14.7.x. Since then MyPaint closes as soon as I try to draw. Mouse works fine but Tablet closes MyPaint.

I found an old article in 2016 where someone had a similar issue and there were instructions on how to resolve but I can find that article again (I didn’t note the link).

I have contracted Huion and they send me an updated Firmware patch but this has not resolved MyPaint issue. I have uninstalled reinstalled Huion drivers and MyPaint. Even tried the stand alone version. Downloaded and installed both onto my laptop which I have not used either. Same issue still applys.

I had not downloaded GIMP so did that. Tablet did not immediatly work. Found under devices only Aggregated Device is available which is also what shows in MyPaint. But in Gimp I was able to add the HUION tablet and erasor which allowed me to use my Tablet. MyPaint does not have this feature.

So I have created an account and logged in here to post this issue as I have not found a solution.

From the little use I had of MyPaint I really enjoyed it and want to get back into it.

Can someone please point me in the right direction. Is there anything I can do to get this working again?

I will also try this Alpha version that has been listed.

Update: alpha does same. It actually doesn’t even load.

Update 2: new driver released for Huion 14.7.6. Did not resolve.

I have Corel Essential Painter 6 and it works fine, even with Tilt. I will use that in the interim but I would still really like to use MyPaint. Any suggestions would be appreciated.

Basic System Details

Intel i5-2600k 4.2Ghz, 16GB, 512GB SSD

MyPaint version: 1.2.1
OS: Windows 10 Pro 1803
Make and Model # of Graphic Tablet: Huion H950P

Please Tell Us How to Reproduce the Problem in Steps.

Open program. Mouse draws. Goto use pen and MyPaint closes.

Can you try the latest build here?

The problem is still there after installing v. 2.0.0 alpha master .430. Any option?

I have the exact same issue using Huion H640P.

Please see

Probably a gtk issue. If you could verify withgtk3-demo and follow up with that bug report
That might be helpful

Have come back to try and get Mypaint working.
The Alpha version does not resolve as mentioned by others.

I followed the link to the discussion and tried all that was suggested.
I too did was not still successful but see the issue appears to be GTK.

As someone mentioned Mypaint V1 works. I downloaded this and can confirm that works fine.
So for now I will use Version 1 until the issue is resolved.

For me it is not going to be a big issue as I am just getting to grips with drawing with a tablet.
As I’m not a good drawer whatever new features the latest has, I probably wont notice.

The thing I like is the unlimited canvas :slight_smile:

Just tried V2 Alpha. MyPaint closes as soon as I put pen to tablet. So same issue. So back to V1 it is.

I still like the program :slight_smile:

I commonly use Blender for 3D modelling and trying to use its Grease Pencil for drawing. I had an issue where it stopped rendering images and would close for apparent reason and was getting worse. So yesterday I finally got around to upgrading W10 1903 release. I had to then also reinstalled Nvidia graphics drivers. Once I had done this, this issue with Blender was now resolved.

So today I was thinking. If this resolved my Blender issue I wonder if the latest version of MyPaint will now work? So I downloaded and installed…low and behold it now works!!!

Version 2 is now working with my Huion H950P Tablet without an issue.
So now I can continue to use :slight_smile:

Just thought I would share.

Graphics Tablets are usually plug , install drivers and play. As long as MyPaint supports tablets the the tablet should work. I’m using a XP-Pen Deco 03 digital tablet , it works pretty well with mypaint , GIMP and Blender .