How to activate the eraser in Mypaint using a Wacom Intous Medium Pro?


I bought a Wacom Intous Medium Pro today and installed Mypaint. For some unknown reason, the eraser on the back of the pen does not always work.

Any idea how to make it work in a reliable way?

Question, what Operating System are u using?


I am using Windows 7.

First thing i recommend, if you haven’t already done it, is to go to and get the latest driver. The drivers that are supplied with devices are hardly ever the latest available, and there might be a bug that’s been fixed since the driver CD was created. Apart from this, i don’t know anything about wacom on windows.

would like to give a request of making it possible to address a mousebutton to the eraser-function .
i use win 7 laptop ,mypaint 1.2.0 64bit and use a penmouse like this .
that way i could easily draw and correct the lines with one hand only. so i can rest my head in other hand . :raised_hands: . now i use the undo-function , which isnt really the same .
sorry for misusing this thread , but i couldnt find a place to put my please .
i like the program , and like using it . good work . thank you . wfg carypt

i also tried to change between 2 coulours ( black and white ) with mousebutton 3 , but that way it changed in steps from white , grey to black .

I’m not sure about Win7. But for 8 and 10 it is strongly recommended to disable some of the Windows pen “features” like Flicks and Hold-to-Rightclick. It seems like wacom and windows often trip over each others feet. So it’s also a good idea to enable/disable different settings in the wacom properties and test it. E.g. “Double click distance” is known to cause trouble in Photoshop and should be off. “use Windows ink” is also worth a try. You can even enable/disable wacom settings per application… that’s what I usually do, when the pen behaves funky…

You probably know already: MyPaint remembers the pen you pick with the eraser end. So if you pick a normal brush, it won’t erase :wink:

I get some erratic behaviour with the stylus detection in win 7, was the same in XP, all MyPaint versions I tried. Sometimes it seems to not notice the change.
I just turn the stylus over and back, and it works again (back, tip and back again).

What doesn’t work is switching styluses (stylus, styli?). I have two same model stylus. Some programs recognize them and remember and switch tools accordingly, MyPaint treats them as the same.

Off topic

Yes. Personally I prefer the ‘es’ ending as it follows the regular english plural rules for words ending in a sibilant sounds.

1 Like