Externally hosted images don't show on the forum

I noticed my images on the forum don’t show, when they’re hosted on another site (different from the ones which are hosted on the forum). Is it a bug or just a “feauture” ? Or maybe the Altervista server is blacklisted ? I hope it’s not, it’s a safe web space I use for years… no problem with that, so far.

Hi! The website (emanuelepepi.altervista.org) seems to have an invalid/untrusted SSL certificate.

This site here uses encryption (see the “https” in the url) but your image URLs are unencrypted (http). It seems the browser blocks them or tries to upgrade your URLs to https automatically but since the certificate is invalid they can’t be loaded.

I guess the website admin has to setup their certificates properly in order for this to work here. You can test the connection here: https://emanuelepepi.altervista.org/ (no warning should appear if everything is setup correctly)

Well, then I guess that final “s” at the end of it stands for " snob " (like Hyper Text Transfer Protocol for Snobs), otherwise I would never be able to understand how and why a simple unencrypted image could cause troubles or worries, lol.
Living in an age of insecurity, discrimination and fear, aren’t we… :frowning:

I mean, it’s a JPG. Not an EXE, dayum…

Oh just to clarify : my site is untrusted by who exactly ? Maybe if I can talk to him, I’ll convince it’s no problem, lol!

Jokes aside, I think it’s all due to the settings of my host. The activation of the super-protocol is now in progress, Sir, aye aye! -_-’

Meh, even if I enabled httpS on my site (and it is now magically “secure”… lol!) … the images still don’t show on the forum. :frowning:
maybe the automatic ssl upgrade of the forum doesn’t work at best ? or is it something not so comfortable afterall ?
it’s so bad people can’t see my artworks… I don’t feel encouraged in posting :frowning:

well, try replacing the http with https in your urls. example:

that could do for the next pictures, but older posts cannot be edited, so I can’t change their url