Can't Import/Paste Images

Description of the Problem, or Question?

I’m trying to paste an image to a layer so I can practice tracing out simple objects, but whenever I try to use Ctrl+V, it says that there is nothing on the clipboard. I don’t even know how I would go about checking my clipboard, and I am completely sure that I coppied the image because when I try to paste it on another program, it works. But the only other solution I’ve been able to find was do it manually through the Menu>Layer>Paste layer from clipboard, but that only leads to the same outcome.

Basic System Details

ASUSTek Computer Inc.
Intel Core i7
8.00 GB RAM
Pen and Touch Support
MyPaint version:
1.2.1+gitexport.bcf5a28d (Not sure if the extra bit is necessary or not, my first post on here.)

Operating System + Version:
Windows 10

Make and Model # of Graphic Tablet:
Small Intuos Wacom Tablet, Model # forgotten

Please Tell Us How to Reproduce the Problem in Steps.

  1. Open Mypaint
  2. Copy an image off of another program
  3. Either press Ctrl+V or open Menu>Layer>Paste layer from clipboard

Are there any Errors Popping Up? If so, paste the text in the area shown below.

Clipboard does not contain an image

Could you install this latest alpha build and see if the problem still persists? MyPaint has gone trough a lot of changes since it 1.2.1 release this past January. You probably need to make sure to uninstall the previous version, and backup any configs you want to keep.

I just installed the latest version I could find a week or two ago, could you direct me to the version that you are talking about?

Okay I fixed the link to point to the correct ones. I’m going to assume you are using a 64-bit version of windows 10.

I installed the 1.3.0 version, and I’m still having the same trouble.I’m guessing It’s a problem with my PC since no one else is having these problems, although I’m still able to paste copied images on other programs.

I am having the same issue. I tried the steps provided by the Admin but I am still getting the same error. The only way iv’e found to open an image is by saving it first and then opening it.

Same problem. I can only fix it by pasting into gimp, then copy pasting from there.

Testing version 1.3.0-alpha+git.8a0a9160 seems to have fixed this problem for me.

Not to resurrect a dead thread, but I downloaded the latest downloadable alpha version of 1.3.0 and this problem is still an issue for me, which is a shame, because for redraws of old art and stuff it’s nice to have the option.