Cannot open .ora files

I’m currently using Mypaint to illustrate comic books on an Asus Sonicmaster X540SA, 4GB, 64x laptop running Windows 10. As of the latest windows updates, I can no longer open my .ora files. I’ve been using Mypaint version 1.0 for a while now because it’s always worked perfectly with my Wacom Cintiq where other versions had buggy issues. It’s my absolute favorite and most dependable program to draw in. But I’ve tried each version of Mypaint I can find, and none allow me to open the .ora files. The files still open on other devices, so I know they aren’t corrupted. On Mypaint 1.0 I get an error message stating :
Traceback (most recent call last):
File “C:\Program Files (x86)\MyPaint\\gui\”, line 333, update_preview_cb(no details)
filename = filename.decode(‘utf-8’)
pixbuf = helpers.freedesktop_thumbnail(filename)
if pixbuf:
File “C:\Program Files (x86)\MyPaint\\lib\”, line 168, freedesktop_thumbnail(no details)
# use the largest stored thumbnail that isn’t obsolete
pixbuf = gdk.pixbuf_new_from_file(fn)
if file_mtime == pixbuf.get_option(“tEXt::Thumb::MTime”):
GError: Failed to load image ‘C:\Users\rabid\AppData\Local\mypaint\thumbnails\large\a69cd6c55c6d7b8763c39c138c4a74a7.png’: Image has zero width

On the latest version, it just tells me the file is not a zip file.

How can I get this functioning again? Does anyone know what suddenly caused the problem? I have so much work in those .ora files. It would be awful if MyPaint stopped supporting them.

If you navigate to C:\Users\rabid\AppData\Local\mypaint\ in your file explorer, try renaming the “thumbnails” folder to “thumbnails.bak”. Then try to open your ora files again.

Tried that. Now I get this error message.

Traceback (most recent call last):
File “C:\Program Files (x86)\MyPaint\\gui\application-dot-py”, line 133, at_application_start(*junk=())
File “C:\Program Files (x86)\MyPaint\\gui\drawwindow-dot-py”, line 46, wrapper(self=<gui.filehandling.FileHandler object>, *args=(u’C:\Users\rabid\Desktop\chissue3\25.ora’,), **kwargs={})
func(self, *args, **kwargs)
# gtk main loop may be called in here…
File “C:\Program Files (x86)\MyPaint\\gui\filehandling-dot-py”, line 249, open_file(no details)
self.doc.model.load(filename, feedback_cb=self.gtk_main_tick)
except document.SaveLoadError, e:
File “C:\Program Files (x86)\MyPaint\\lib\document-dot-py”, line 389, load(no details)
load(filename, **kwargs)
except gobject.GError, e:
File “C:\Program Files (x86)\MyPaint\\lib\document-dot-py”, line 590, load_ora(self=<lib.document.Document instance>, filename=u’C:\Users\rabid\Desktop\chissue3\25.ora’, feedback_cb=)
tempdir = tempfile.mkdtemp(u’mypaint’)
z = zipfile.ZipFile(filename)
print ‘mimetype:’,‘mimetype’).strip()
File “zipfile.pyo”, line 696, init(no details)

File “zipfile.pyo”, line 721, _GetContents(no details)

File “zipfile.pyo”, line 716, _GetContents(no details)

File “zipfile.pyo”, line 728, _RealGetContents(no details)

BadZipfile: File is not a zip file

Have you tried a Alpha build?

Also, have you tried opening the ora files on the same computer, but with GIMP? Make sure you have backups before you fool around with other programs though.

They all open fine in Gimp and Irfanview.
I don’t know what an Alpha build is.

Ok, now it is working again. I think I just had to restart after making that folder change. Thank you!

1 Like