Building Dothiko's Fork of MyPaint

Hello, dear Mypainter

Maybe one can help me.
I am interested very much in Fork by Dothiko and have it already sometimes
tried out.
Now I have a new computer.

I have if error message follows

lg peter

Could you give us the exact steps in how you built MyPaint? Also which branch of @dothiko’s fork are you are testing out? There could be a quirk on that fork that is different from vanilla MyPaint.

@dothiko since this is your fork, could you help us here in solving this?

On a side note, I’m going to move your thread over to User Support and re-title your Thread so people understand you need help building MyPaint.

Hi,PeterToybulldog and odysseywestra.
I’m very sorry that I forgot to git-add new python file ‘gui/’ !
This is fixed now.

Hallo Odysseywestra

Thanks for your quick Support

If I Mypaint Installing, have installed I before the PPA of Gimp-edge (Otto kesselgulasch).

Therefore I agree libmypaint which I install with Synaptic.

I download to me the code of Github/MyPaint (in my case: Fork from dothiko)

Under (/home) I provide to me a new folder (for example: Mypaint_dothiko) where I (. zip) unpacked .

After I all dependence install has:

In the unpacked folder (Mypaint_dothiko) I open terminal and give to the order:

Then I test whether Mypaint functions.
With the order:

And if everything is OK then it further goes with the order:

And then I can use Mypaint in my system like all the other programmes.

Lg peter

Hallo dohthiko

Many thanks now I can take pleasure again with yours fork.
Everything OK I has installed yours fork again :blush:
I am very happy like in general one which develops future for mypaint.
thanks and Lg Peter

Hallo Dothiko

I hope I do not nerve.
As you see in the video, functions do not work:

Bezier Curve
Polygonfill ( Bezier Curve , Polyline )

Layer (the preview image)

Thank you

Hi,PeterToybulldog,Thanks for uploading your video!:smiley:

But… sorry, I have no Idea what going on…:cold_sweat:
It seems that something going wrong in input event handler…
My environment is , Xubuntu 16.04, amd64.

For your reference, I uploaded a video how it work on my system:

(A little too quick operation, it seems to be due to recording software…)

I’ll try ubuntu 16.04 later!

I just tested my branch in Unity desktop environment of clean installed ubuntu 16.04.
but, I cannot reproduce problem…:disappointed_relieved:

For your reference, I uploaded video clip.

Some visual glitch is same(around ellipse tool)
but mouse input correctly processed…

My main PC is DIY one, and this test is done in VAIO T laptop.
Mypaint branch is downloaded from github as zip file, and extract it in VAIO.
I use wacom intuos CTH-680 and logitech mouse m100r and m325.

Have you installed any additional desktop programs?
Both of my tested environment are almost vanilla one.

Or, possibly, something changed(enhanced) in GTK3, and it might affected to my codes…
Actually My experimental tools (exinktool and beziertool and polyfilltool) are largely changed from vanilla mypaint, that changed parts by me might not follow gtk3 enhancement and things going wrong.
I’ll continue researching around such thing.
Anyway, thanks for your reporting :smile:

Hello Dothiko,

I had time to try.

After I have installed Kubuntu, I have left everything so, and first libmypaint and then yours
Github installed.

Hurray Hurra everything has now worked.
Even the new possibility to use Mypaint in Opentoonz.
But for Opentoonz I have to install so everything runs smoothly the AMDGPU-PRO.
But after that I had the same problems as my video with Ubuntu.
Now I know the cause, it is the graphics card (AMD RX 460) when I install official drivers.

I will be able to handle it and I will be happy to use your Fork-Mypaint.:blush::relaxed::smiley:

Thank you for your effort

Lg peter

Hi peter,
That’s good to know!! :smiley:
I have no idea why RX460 driver cause problem, I hope it would be fixed anytime soon…
Anyway, Hope things are going well for you :smile: