Bounty available for Surface Pro 3+4 pressure issues

People wanting to use MyPaint fully on newer versions of the Surface Pro tablet are willing to pay a bounty for an important bug to be fixed. It’s one where our core development team don’t have hardware available for testing, so not much progress has been made yet. It’s up on Bountysource right now, if you’re intersted in getting this one fixed. You can help by backing the campaign, or claim the bounty by fixing the bug! This is MyPaint’s first foray into BountySource, so I’m keen to see how it goes. It was prompted by one of our wider community, @scooter-dangle, posting the first bounty. Thanks, Scott! BTW, Bountysource are quite open about how it works in case anyone has any doubts about this. The issue might be moderately hard to fix: I kinda suspect it’s actually a bug with GDK, one of the libs MyPaint is built against. There may be things to do in MyPaint as well, we’re just not certain yet. Even if it’s really a problem elsewhere, a tested fix for GDK’s win32 backend would probably meet our backers’ approval. If it is a GDK bug, it should be reported in the GNOME gtk+ tracker as well (with a link back to ours). Here’s the bounty post: Feel free to draw us an actual wild–west–style bounty poster if you want!
This is a companion discussion topic for the original entry at

We should also see if this problem is happening on Linux with those surface devices as well. That way if there are any N-Trig problems on Linux as well, we could try to get those fixed as well.

I’ve been hoping for ages that this would get solved, so I contributed. I was using MyPaint before I switched to a Surface Pro 3 and it was already my favorite drawing program then, but I was convinced that MyPaint and Surface Pro together would make for the ultimate drawing experience. Imagine my disappointment when it was unusable! Anyway, godspeed to anybody who takes on this task.

Im not sure if this has already been reported else where, or even helps, but I have a Surface Pro 3, and also have used a few distros of linux on it. So far I have tried 3 flavors of Ubuntu, Fedora, and Linux Mint ( Gnome, KDE, Cinnamon, and Xfce environments) and in all of those distros the latest release of Mypaint works 100% perfectly for me. The only function I could not use was the eraser button and right click; however that was because of Linux not having full compatibility with the surface pro…not an issue with Mypaint.

(Edit: Forgot to add, Ive noticed that when I run Mypaint in Win10, as soon as the application starts, I will have pressure sensitivity until I either lift the pen from the screen or press one of the buttons to pan the canvas. Again, not sure if that helps.)