Which Graphic Tablets Models Work on MyPaint 1.2.0+?

I want to start a thread wiki to help the community get an idea of which graphic tablets work with MyPaint out of the Box. To help out simply click on edit button below and add your tablet in. Be sure to add which OS the tablet works on as well. Also please include the model number so our developers and contributors can troubleshoot those tablets if need be. If there are any steps that required you to get it to work, just add it a bullet point below the tablet. I will keep an eye on this thread and edit it to keep it consistent.

MyPaint on Windows and OSX are considered Beta and will have issues with pressure with most Graphics Tablets.

Wacom Tablets and Monitors


  • HP TX2500 - Wacom Embeded - Linux(YES) - Windows(No Pressure) - OSX(Unable to install on)
    • Use Magick Rotation for Screen Rotation.
    • Good Basic, and resonably priced TabletPC to get started with.
    • Recommended Distro: Ubuntu Mate
    • Highly recommended to get a SSD for this guy.
  • Wacom Cintiq Companion 2 - DTHW1310M - Linux(YES) - Windows(SLOW) - OSX()
  • Thinkpad x220T - Wacom Embeded - Linux(YES) - Windows-7(NO) - OSX()
  • Microsoft Surface 3 - N-Trig - Linux() - Windows(YES) - OSX()
    • the alpha builds seem to fix pressure issues in the 32 and 64-bit versions, but pen pressure doesn’t work with either version in the current 1.2.1 release (as of Dec. 2017.)

Huion Devices
NOTE: Some Huion and other third party tablets my need the to use DIGImend Driver drivers on Linux.

  • H610PRO - Linux(YES) - Windows(YES) - OSX()
  • H420 - Linux(YES) - Windows() - OSX()



  • Ace Cad Enterprise Co., Ltd Tablet - 5x3.75 drawing area - Linux(YES) - Windows() - OSX()
  • Bosto22HD - Linux(YES) - Windows() - OSX()
  • @Aidan_Walton maintains a kernel drive for the Display Tablet on Github.
  • Genius i405X - Linux() - WIndows(YES) - OSX()
    • Tested on Windows XP Pro 32-bit / Windows 8.1 64-bit
  • Ugee HK1560 - HK1560 - Linux() - Windows() - OSX()
  • Artisul Pencil - Linux() - Windows(YES) - OSX()
  • Yiynova MVP10U - Linux() - Windows(YES) - OSX()
  • XP-Pen Artist 13.3 - Tablet Monitor(1st & 2nd Gen) - Linux() - Windows(YES) - OSX()
    • First Gen has 2048 levels of pressure.
    • Second Gen(link above) has 8192 levels of pressure.

NOTE: This post is set as a Wiki which requires at least Trust Level 1 (Basic User) or higher to be able to edit this post.


I’m using a Cintiq Companion 2 64 gig. It works in windows 10 but too slow to be useful. Not the fault of MyPaint though, I tried Sketchbook Pro and Photoshop and they were even worse.

Now I use Ubuntu, and MyPaint works pretty good. A bit laggy with larger brushes.

I had an Intuos 2 A5 and it worked flawlessly with MyPaint in Ubuntu.

Linux Mint 17.2, using MyPaint 1.2.0-beta.4+gitexport.ee1f5bc

The following works fine with no issues.

  • Ace Cad Enterprise Co., Ltd Tablet (5x3.75) [really old tablet from the 90s]
  • Monoprice Tablet 12x9
  • Huion H610PRO*
  • Huion H420
  • Wacom Bamboo Pen (CTL-470)

*I forgot if I had to get the latest drivers just to get it work. [DIGImend]

Next I might try Elitebook 2730p and my other 2 Thinkpads (x41 & x60). I mean they work out of the box but they have the older version of MyPaint installed. Too afraid to update on the Elitebook since I have become too comfortable with it.

Can confirm, that these work on Windows (with proper drivers ofc), and Linux (tested on Ubuntu).
Wacom Bamboo Fun - CTE-650
Wacom Intuos 4 Medium - PTK-640
Wacom Intuos Pro Medium - PTH-651

Good idea to make this list, @odyssywestra!

Can I ask people to report only whether the tablet works with 1.2.0 please?

1.2.0 is what I’m using. Haven’t tried the Intuos with it, but I don’t see any reason that it shouldn’t work.

I can confirm that MyPaint 1.2.0 works well enough for real work with the following tablet models and combinations :smile:

  • Huion H610 Pro :ok:
    • Linux (GNOME 3.18ish under recent Debian testing/unstable, xserver-xorg 7.7): works correctly as a pressure-sensitive tablet, pad buttons untried.
    • Windows 7, stock (? IIRC) drivers: works correctly as a pressure-sensitive tablet, minor position glitches just after starting MyPaint which seem to go away after the first few seconds of use.
  • Wacom PTH-650 (USB wired connection) :ok: :100:
    • a.k.a. “Wacom Inutuos 5 Touch M”
    • Linux (GNOME 3.18ish as above, Xorg as above): works great, hotkeys can be assigned in GNOME.
    • Windows 7, recent drivers: works great
  • Wacom PTH-650 (via Wacom Wireless Accessory Kit) :ok: :thinking:
    • Linux (GNOME 3.18ish as above, XOrg as above): works same as a USB connection BUT occasionally glitches and drags. Unplugging the adaptor and turning the tablet off and on again, then plugging the adaptor in fixes it.
      • Needs a recent libwacom2 for the pad buttons to be bindable. Presents as an Intuos 5 Touch, but with a different name.
    • Untried under Windows.

(BTW, I’m not using the digimend patches or out-of-tree HID drivers for the Huion, and it Just Works to an extent. Hopfully those patches are integrated in the more recent kernels. Currently I’m running Debian’s linux-image-amd64 at kernel version 4.4.0, but I’ve not tested with the Huion for a bit. I can test again and report back more thoroughly if people want.)

I assumed that the question was if it works with MyPaint once the drivers are up and running.

I do have to reload the driver modules every other reboot, and recompile them every fifth reboot or so. But that’s more an issue with Ubuntu than MyPaint.

Hello, Intuos 3 A4 works fine in windows.

Report as check in Linux.

Okay list has been updated… Man I really wish Discourse supported tables.

There are plugins that could be added for tables like https://meta.discourse.org/t/table-plugin-version-2-1-0-2015-08-27/31183

That a great suggestion, but it’s a paid plug-in which is something I want to avoid for now.

I got my Huion 580 to work in MyPaint. I’m on Ubuntu 14.04 and have Digimend Drivers installed. :smiley:
Edit: Oh I just realized I installed MyPaint 1.1.0 I will have to try the new version soon and let you guys know.

Huion 540 works with everything except the brushes! Any idea why?

Just letting everyone know that I’ve made this post a wiki so anyone can add their Graphic Tablet and leave notes. Please keep it consistent.


This might be a good candidate for testing. User review on Amazon states the older Monoprice 19" Model # 110707, compatibility with Linux + Digimend. Been researching the newer 22" version of this; Linux compatibility seems dubious but maybe not? Just wanted others to know.

I use Mypaint mostly for pen-drawings because of the dynamics with wich it reproduces the pen-pressure on my drawing tablet (a TRUST “wide tablet” I use since several years, also in previous releases of Mypaint).

But since I use Windows 10, and after the installation of Mypaint W64 (1.2.1-beta.1)
the drawing with the pen is very strange:

  • the lines come very slowly on the screen, and are interrupted and extended with horizontal “spikes”’ (see drawing)

The program responds quickly enough with the mouse and even faster with the touchscreen (I got an All in One computer)

With Photoshop and Painter however my pen works still fine, but as always the effect of the pen pressure on the thickness of the lines is not sufficient (that’s why I use MyPaint)

I installed the TRUST-driver I found on their site, but still no result.

Should I download another version, or is there a setup to do in MyPaint? I really would like to continue using this fine program, and the newest version offers thrilling feautures I see.

Thanks for any answer


I use the Wacom Cintiq 21 UX -Win7 64bit- MyPaint 1.0/1.2
MyPaint 1.0 freezes when you use big datas and many layers. ( I know that MyPaint 1.0 isnt supported anymore) MyPaint 1.2 cant open pictures created with MyPaint 1.0 . Now I`m actually creating big paintings in MyPaint 1.2 too because I want to kow if this program can handle big datas with many layers.

Best wishes,
Haku and the Mermaids

Just got the Thinkpad x220T and used the latest version of MyPaint on the non-genuine Windows 7 (silly seller had to do that,) and it does not work out of the box. After wiping out Windows and installing Linux Mint 18, install MyPaint 1.2.0, it works with no problems.

I’ll try to find time to install the newer version of MyPaint on the older ThinkPad tablets.